[phpBB Debug] PHP Warning: in file [ROOT]/common.php on line 122: require() [function.require]: Unable to allocate memory for pool.
[phpBB Debug] PHP Warning: in file [ROOT]/viewtopic.php on line 18: include() [function.include]: Unable to allocate memory for pool.
[phpBB Debug] PHP Warning: in file [ROOT]/viewtopic.php on line 19: include() [function.include]: Unable to allocate memory for pool.
[phpBB Debug] PHP Warning: in file [ROOT]/includes/session.php on line 554: include_once() [function.include-once]: Unable to allocate memory for pool.
[phpBB Debug] PHP Warning: in file [ROOT]/includes/session.php on line 1042: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/session.php on line 1042: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/session.php on line 1042: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
www.linderdaum.com • View topic - Visual C++ 2010 Express

Visual C++ 2010 Express

Problems building or running the engine, questions about how to use features and so on.

Visual C++ 2010 Express

Postby Scilly_guy » February 18th, 2012, 1:19 pm

I am having a little trouble getting started, I have some experience with visual studio but have not used it in the last 4 years and I am feeling very rusty. I have Downloaded SDK 0.6.04, OpenAL and Python. Using the project creation wizard I have created a VC++2010 project but when I try to open it I get the VS conversion wizard, by unchecking the overwrite option I end up with the project open. When I try to build the project I get 2 warnings and 1 link error:
Code: Select all
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppBuild.targets(990,5): warning MSB8012: TargetPath(C:\LinderdaumSDK\Apps\Helloworld\.\Helloworld.exe) does not match the Linker's OutputFile property value (C:\LinderdaumSDK\Apps\Helloworld\Helloworld_Win32Debug.exe). This may cause your project to build incorrectly. To correct this, please make sure that $(OutDir), $(TargetName) and $(TargetExt) property values match the value specified in %(Link.OutputFile).
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\Microsoft.CppBuild.targets(992,5): warning MSB8012: TargetName(Helloworld) does not match the Linker's OutputFile property value (Helloworld_Win32Debug). This may cause your project to build incorrectly. To correct this, please make sure that $(OutDir), $(TargetName) and $(TargetExt) property values match the value specified in %(Link.OutputFile).
1>LINK : fatal error LNK1104: cannot open file 'LinderdaumEngine.lib'


I'm feeling like a newbie again, I am completely out of practice dealing with visual studio and engines, if you could help me get your engine up and running on my machine I would be very grateful.
Scilly_guy
 
Posts: 10
Joined: January 5th, 2012, 12:52 pm

Re: Visual C++ 2010 Express

Postby SergeyK » February 19th, 2012, 6:57 pm

Could you please post your solution project (zipped) here or give a link to it?
SergeyK
Site Admin
 
Posts: 11
Joined: November 3rd, 2011, 8:14 am
Location: SPB

Re: Visual C++ 2010 Express

Postby Scilly_guy » February 19th, 2012, 11:59 pm

Hopefully this is all the files you need, I wasn't sure which I could leave behind to make the zip small enough for the forum. I created a new solution but the problem is exactly the same as for the helloworld app. I hope we can get your engine to work on visual studio express, I'm not sure why the files needed converting.
Attachments
testing.zip
(5.28 KiB) Downloaded 472 times
Scilly_guy
 
Posts: 10
Joined: January 5th, 2012, 12:52 pm

Re: Visual C++ 2010 Express

Postby ViktorL » February 20th, 2012, 11:34 am

Hello, Scilly.

From what I see in the Build log, I can make a conclusion, that the LinderdaumEngine.lib is not built on your machine (well, that's quite obvious...).

Also, the build log you have posted tells that yout have a solution with a single project (testing.vcxproj).

The problem has nothing to do with VisualStudio Express, it is a matter of setup. We supply some precomipled .lib files, but it is better to build the Engine's .lib-file locally for your PC.

So, the solution might be the following:

0. Run the rebuildLSD.py script in C:\LinderdaumSDK
1. Create <YourProject.sln> in C:\LinderdaumSDK
2. Add <Linderdaum.vcxproj> to the newly created .sln
3. Add Apps/testing/testing.vcxproj to the newly create .sln
4. Call the "Project dependencies" dialog for the <testing> project and Check the "LinderdaumEngine" (your 'testing' project uses the engine, so the engine must be built before your project, or you will get link errors once again)
5. Now, hopefully, your project can be built.
ViktorL
 
Posts: 10
Joined: February 20th, 2012, 11:24 am

Re: Visual C++ 2010 Express

Postby Scilly_guy » February 20th, 2012, 1:16 pm

When building the engine:
Code: Select all
Src\Linderdaum\Environment.cpp(60): fatal error C1083: Cannot open include file: 'Generated/Exports/Exports_Core.h': No such file or directory
Src\Linderdaum\SysEnv.cpp(24): fatal error C1083: Cannot open include file: 'Generated/Exports/Exports_Core.h': No such file or directory
Scilly_guy
 
Posts: 10
Joined: January 5th, 2012, 12:52 pm

Re: Visual C++ 2010 Express

Postby SergeyK » February 20th, 2012, 3:06 pm

1) Do you have Python 3.x? (not 2.x - that is very important)

2) Have you started rebuildLSD.py script from the engine's folder?
SergeyK
Site Admin
 
Posts: 11
Joined: November 3rd, 2011, 8:14 am
Location: SPB

Re: Visual C++ 2010 Express

Postby ViktorL » February 20th, 2012, 3:11 pm

It really looks like something went wrong with rebuildLSD.py script invocation which is mandatory for the successful engine build.

1) Do you have the <SDK>/Tools/LSDC/lsdc.exe file ?
2) What does the textual output from rebuildLSD.py look like ?
3) In case nothing is wrong there, check for existence of the <SDK>/Out folder (it is the temporary folder where LSDC.exe puts its intermediate output before copying it to Src/Generated)
ViktorL
 
Posts: 10
Joined: February 20th, 2012, 11:24 am

Re: Visual C++ 2010 Express

Postby Scilly_guy » February 20th, 2012, 10:06 pm

1) Yes
2) If its output to a file what its called, the console doesn't pause when it ends, I added "x = raw_input("Press Enter")" to try and get a pause but still nothing.
3) I have SDK/out

I really am sorry to be asking what feels like stupid questions.
Scilly_guy
 
Posts: 10
Joined: January 5th, 2012, 12:52 pm

Re: Visual C++ 2010 Express

Postby ViktorL » February 21st, 2012, 10:08 am

>> I really am sorry to be asking what feels like stupid questions.
It is OK, these are quite normal.

Please, try running "python rebuildLSD.py > rebuild.log" in the command prompt and post the rebuild.log file here.

The error is definitely there, we just cannot be sure what it is without detailed technical log.
ViktorL
 
Posts: 10
Joined: February 20th, 2012, 11:24 am

Re: Visual C++ 2010 Express

Postby Scilly_guy » February 21st, 2012, 7:25 pm

cmd wrote:The application has failed to start because its side-by-side configuration is incorrect. Please see the application event log or use the command-line sxstrace.exe tool for more detail.
Traceback (most recent call last):
File "rebuildLSD.py", line 102, in <module>
os.remove( "Debug_NETTypes.list" )
WindowsError: [Error 2] The system cannot find the file specified:'Debug_NETTypes.list'


Looks like its nearly finished, are those last lines important?
Scilly_guy
 
Posts: 10
Joined: January 5th, 2012, 12:52 pm

Next

Return to Help

Who is online

Users browsing this forum: No registered users and 1 guest

cron